BUS MS Exchange Issues: Difference between revisions
No edit summary |
|||
| Line 25: | Line 25: | ||
Although this is not an official recommendation from Microsoft, this key will get recreated after the machine is restarted. | Although this is not an official recommendation from Microsoft, this key will get recreated after the machine is restarted. | ||
==Exchange 2010== | |||
* Exchange 2010 requires the latest hotfix be applied to bring the BUS client up to version 5.5.7.4. You can download it here: ftp://ftp.swcp.com/pub/bus/hotfix_5574/ Download both the '''obm-win-5574-hotfix.zip''' and '''README''' files. Follow the instructions in the README to apply the update. | |||
==See Also== | ==See Also== | ||
[[Category: BUS]] | [[Category: BUS]] | ||
[[Category: MS Exchange]] | [[Category: MS Exchange]] | ||
Revision as of 17:07, 21 December 2010
There are two approaches to backing up Exchange: (a) the traditional approach of backing up the files which comprise Exchange and the message store or (b) "brick-level" backup of individual mailboxes and contact databases. Currently the SWCP BUS only supports the traditional method. "Brick-level" backups may be supported in a future version.
Common Exchange Backup Problems
Here are some common errors encountered when doing Exchange backups and how to resolve them.
Expected log sequence 'xxx' but found 'SERVERNAME\Microsoft Information Store\First Storage Group\E000xxx.log'
This error occurs when the log sequence of MS Exchange was altered by other backup software, e.g. NTBackup. Thus when OBM next performs a MS Exchange backup, the Exchange log sequence would not match the one that it is expecting. With the broken sequence, the Exchange server cannot be restored to its latest state.
To resolve this problem, you need to deactivate all other backup software that is operating on MS Exchange, and then you need to perform a Full MS Exchange database backup manually via OBM.
Alternatively, instead of backing up transaction logs during the weekdays, you can consider doing Full Exchange Database backup on a daily basis with the In-File Delta option enabled. This should avoid interference from other backup software while keeping the amount of upload data to a minimum.
No *.stm found
If you get an error that looks like No *.stm found for database 'ServerX\Microsoft Information Store\First Storage Group\Mailbox Store (ServerX)' , this suggests that the .stm file on server may have been corrupted or found missing. To resolve this error, please perform a Full MS Exchange backup manually via OBM.
File size of SystemState.bkf not correct
If you see an error like this:
[SystemStateBackup] File size of "C:\Directory_Path\SystemState.bkf" does not appear to be correct.
The cause is a Microsoft Volume Shadow Copy issue. The fix is to remove a registry key:
- Please backup the registry key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\EventSystem\{26c409cc-ae86-11d1-b616-00805fc79216}\Subscriptions
- Remove this registry key along with all its sub-keys
- Reboot the machine
Although this is not an official recommendation from Microsoft, this key will get recreated after the machine is restarted.
Exchange 2010
- Exchange 2010 requires the latest hotfix be applied to bring the BUS client up to version 5.5.7.4. You can download it here: ftp://ftp.swcp.com/pub/bus/hotfix_5574/ Download both the obm-win-5574-hotfix.zip and README files. Follow the instructions in the README to apply the update.