BUS MS Exchange Issues: Difference between revisions
No edit summary |
|||
| Line 1: | Line 1: | ||
There are two approaches to backing up Exchange: (a) the traditional approach of backing up the files which comprise Exchange and the message store or (b) "brick-level" backup of individual mailboxes and contact databases. Currently the SWCP BUS only supports the traditional method. "Brick-level" backups may be supported in a future version. | There are two approaches to backing up Exchange: (a) the traditional approach of backing up the files which comprise Exchange and the message store or (b) "brick-level" backup of individual mailboxes and contact databases. Currently the SWCP BUS only supports the traditional method. "Brick-level" backups may be supported in a future version. | ||
==Common Exchange Backup Problems== | |||
Here are some common errors encountered when doing Exchange backups and how to resolve them. | |||
===Expected log sequence 'xxx' but found 'SERVERNAME\Microsoft Information Store\First Storage Group\E000xxx.log'=== | ===Expected log sequence 'xxx' but found 'SERVERNAME\Microsoft Information Store\First Storage Group\E000xxx.log'=== | ||
Revision as of 13:50, 24 June 2008
There are two approaches to backing up Exchange: (a) the traditional approach of backing up the files which comprise Exchange and the message store or (b) "brick-level" backup of individual mailboxes and contact databases. Currently the SWCP BUS only supports the traditional method. "Brick-level" backups may be supported in a future version.
Common Exchange Backup Problems
Here are some common errors encountered when doing Exchange backups and how to resolve them.
Expected log sequence 'xxx' but found 'SERVERNAME\Microsoft Information Store\First Storage Group\E000xxx.log'
This error occurs when the log sequence of MS Exchange was altered by other backup software, e.g. NTBackup. Thus when OBM next performs a MS Exchange backup, the Exchange log sequence would not match the one that it is expecting. With the broken sequence, the Exchange server cannot be restored to its latest state.
To resolve this problem, you need to deactivate all other backup software that is operating on MS Exchange, and then you need to perform a Full MS Exchange database backup manually via OBM.
Alternatively, instead of backing up transaction logs during the weekdays, you can consider doing Full Exchange Database backup on a daily basis with the In-File Delta option enabled. This should avoid interference from other backup software while keeping the amount of upload data to minimal.